Plus Community - for users of ACCPAC & Adagio accounting software

Welcome to the PlusCommunity forums! PlusCommunity is a gathering place for companies running Simply Accounting, ACCPAC Plus, Sage Accpac ERP (ACCPAC Advantage/ACCPAC for Windows), and Adagio Accounting.
New visitors, please click here!

Page 1 of 1 1
Topic Options
#33792 - 05/02/08 08:16 AM cannot access database (error 49153)
Patrick
Member


Registered: 04/04/08
Posts: 8
Loc: Kenya
Hi,
i know this is a common error in Accpac related to database access. we upgraded our servers windows from 2000 to 2003 and after the upgrade accpac was unable to run from client machines thus generating the error 'cannot access database (error 49153)'. interesting enough it runs perfectly from the server without any problem. Could it be I am experiencing the problem coz i installed Accpac and pervasive using the remote desktop? and how can i fix the problem?
_________________________
gthang

Top
#33793 - 05/02/08 08:41 AM Re: cannot access database (error 49153) [Re: Patrick]
Jay Converse Administrator
Member


Registered: 07/31/00
Posts: 7616
Loc: Location, Location
Your clients are pointing to the old server name.
_________________________
Jay Converse
Sage 300 Whisperer

Top
#33796 - 05/03/08 04:28 AM Re: cannot access database (error 49153) [Re: Jay Converse]
Patrick
Member


Registered: 04/04/08
Posts: 8
Loc: Kenya
I did a fresh system manager and pervasive installation and pointed to the new server after the 2003 server upgrade
_________________________
gthang

Top
#33797 - 05/03/08 05:38 AM Re: cannot access database (error 49153) [Re: Patrick]
Jay Converse Administrator
Member


Registered: 07/31/00
Posts: 7616
Loc: Location, Location
"49153" means the client can't see the server. Maybe there's a firewall in the way.

Accpac version?
Pervasive version?
_________________________
Jay Converse
Sage 300 Whisperer

Top
#33799 - 05/03/08 07:23 AM Re: cannot access database (error 49153) [Re: Jay Converse]
Patrick
Member


Registered: 04/04/08
Posts: 8
Loc: Kenya
ACCPAC version 5.4
PERVASIVE Version 9
_________________________
gthang

Top
#33802 - 05/05/08 04:08 AM Re: cannot access database (error 49153) [Re: Jay Converse]
Patrick
Member


Registered: 04/04/08
Posts: 8
Loc: Kenya
Hi Jay,
There is no firewall on the way, I have checked issues to do with access rights on the data folder in the server and everything is OK. Pervasive client was not showing the name of the server and I had to create it hence detecting the respective databases automatically but still getting the same error. I am now running out of options
_________________________
gthang

Top
#33803 - 05/05/08 05:35 AM Re: cannot access database (error 49153) [Re: Patrick]
Jay Converse Administrator
Member


Registered: 07/31/00
Posts: 7616
Loc: Location, Location
Dbspy may give you better error numbers.
_________________________
Jay Converse
Sage 300 Whisperer

Top
#33814 - 05/07/08 12:42 AM Re: cannot access database (error 49153) [Re: Jay Converse]
Patrick
Member


Registered: 04/04/08
Posts: 8
Loc: Kenya
Hi Jay,
when I install Pervasive client transactional engine tests go through without any problem but the next step of testing relational engine i.e. Machine Name and Engine DSN (demodata) is not going through. could this be the reason why this whole thing is not working? and why should the test fail when I am pointing to the right Machine name?
_________________________
gthang

Top
#33815 - 05/07/08 05:33 AM Re: cannot access database (error 49153) [Re: Patrick]
Jay Converse Administrator
Member


Registered: 07/31/00
Posts: 7616
Loc: Location, Location
Yes, that's definitely the problem.

1. You're not trying this through a Remote Desktop Connection (RDC), are you? You need to run Regedit and change HKEY_LOCAL_MACHINE\SOFTWARE\Pervasive Software\Utilities interface\Settings\Restricted Access On WTS client to 0.

2. You might have restrictive network policies that prevent local users from seeing the System DSN's of ODBC.

3. These aren't 64-bit OS's are they? You have to run a different version of ODBCAD32 in that case.
_________________________
Jay Converse
Sage 300 Whisperer

Top
#33816 - 05/07/08 07:28 AM Re: cannot access database (error 49153) [Re: Jay Converse]
Patrick
Member


Registered: 04/04/08
Posts: 8
Loc: Kenya
Thanks Jay, the genesis installation of ACCPAC and Pervasive on the server was after the upgrade to 2003 server, which i did without knowing its effect through RDC. When I tried creating a Database through the control center I was being prompted for a password and after a search and a long struggle on the Net came the idea of editing the Restricted Access to 0 on WTS, which I did and I was able to create the DB and log on to Accpac but on the server. When I tried the client I could not go through. we don't have any restricted network policies coz we are not running accpac for the first time. We are running a 2003 server is it a 64 bit OS i dont know
_________________________
gthang

Top
Page 1 of 1 1


Moderator:  Jay Converse 
Hop to: